Back to overview
Degraded
Increased Slowdown
May 29 at 12:41pm PDT
Affected services
Website
Resolved
May 29 at 01:55pm PDT
We have identified the cause of the slowdown. Most regions are back to normal performance. The remaining regions will soon follow.
Affected services
Website
Created
May 29 at 12:41pm PDT
At the moment, OmniSets is undergoing a slowdown that could potentially impact your user experience. Although all services are still functioning as normal, you may encounter delays and slower response times. It's worth noting that this issue is only affecting certain regions and countries, so it's possible that you may not be affected at all.
Affected services
Website